Hyperledger Fabric - Environment Setup

Hyperledger Fabric - Environment Setup

Hyperledger Fabric - Environment Setup

For any framework to work seamless & flawlessly, you need a clean environment and you should know the basic configuration details. So this article will give you that information.

I will follow this entire series in Ubuntu 18.10, so please follow along if you are an Ubuntu user. I will try to give parallel instructions for MAC.

If you are Ubuntu/Linux users, then you are going to have a “rock-solid” environment and better support from the community. As you know, Hyperledger is under “Linux Foundation”, we have so many contributors/developers who support this operating system than Mac/Windows. Of course, we do have a bunch of contributors from other OS, but Ubuntu/Linux stands top in this.

Ubuntu: 16.04 or above

HardDisk: 500GB & above

RAM : 8GB(Recommended)

Install curl
1) Sudo apt update
2) sudo apt-get install curl
Install Dockers:
1) sudo apt install apt-transport-https ca-certificates curl software-properties-common
2) curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
3) sudo add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/ubuntu bionic stable"
4) sudo apt update
5) apt-cache policy docker-ce
6) sudo apt install docker-ce --> to install docker composer
7) sudo systemctl status docker --> to check docker is running fine background
Install Go
1) sudo apt install -y golang
2) export GOROOT=/usr/lib/golang
3) export GOPATH=$HOME/projects
4) export PATH=$PATH:$GOROOT/bin
5) Set this in .profile file for permenantly
6) . ~/.profile -> this command will help you to refresh the profile without loggingout
Install Nodejs
1) sudo apt-get install nodejs
2) sudo apt-get install npm
Install NVM
1) sudo apt-get install build-essential libssl-dev
2) curl -sL https://raw.githubusercontent.com/creationix/nvm/v0.33.8/install.sh -o install_nvm.sh
Upgrade Node & NPM
1) nvm install 8.11.1 (8.11.1 is the version I am looking for) -> this will upgrade/update nodejs
2) npm install npm@6.4.1 -g --> this will upgrade npm
Install Binaries(Fabric)
------curl -sSL http://bit.ly/2ysbOFE | bash -s   ----
1) curl -sSL http://bit.ly/2ysbOFE | bash -s 1.3.0 1.3.0 0.4.13
So if you want 1.4.0 version, change that accordingly in above command

Once you are done with all the above commands in sequence and if it is run successfully, then your environment is ready with Hyperledger Fabric.

Installing Node / NVM is out of Hyperledger fabric setup, but we may want this to build an application(ReactJS). So have this installed in sequence will help..

For Windows User: please check this link

What's Your Reaction?

like
0
dislike
0
love
0
funny
0
angry
0
sad
0
wow
0